[Crossfire-wiki] [Crossfire DokuWiki] page changed: coding_style_guide

no-reply_wiki at metalforge.org no-reply_wiki at metalforge.org
Mon Sep 3 16:45:24 CDT 2007


A page in your DokuWiki was added or changed. Here are the details:

Date        : 2007/09/03 16:45
User        : kbulgrien
Edit Summary: Various corrections; add doxygen/other notes; Some formatting.

@@ -1,11 +1,11 @@
- The following is a wikified mirror of //crossfire/doc/Developers/programming_guide// from the server source.
+ The following is a wiki-fied mirror of //crossfire/doc/Developers/programming_guide// from the server source.
  
- ====== Section 1 - currently used conventions/hints for new code writers: ======
+ ====== Section 1 - Currently used conventions/hints for new code writers: ======
  
-   - variable abbreviations - ''op'' is short for object pointer, ''ob'' is for object, and ''pl'' is for player.
+   - Variable abbreviations - ''op'' is short for object pointer, ''ob'' is for object, and ''pl'' is for player.
    - Some functions are named using the conventions above - the naming effects what options they take (''insert_ob_in_ob'' takes 2 object structures)
-   - Identation is 4 spaces.  This can be a pain to read, but most functions should be consistent through the function.
+   - Indentation is 4 spaces.  This can be a pain to read, but most functions should be consistent through the function.
    - Some structure elements should never be accessed directly - rather, there are other functions to use the values.
      * ''object->owner'':  This contains the owner id for this object.  Use ''set_owner'' and ''get_owner'' instead.  Directly using object->owner is likely to get unpredictable results.
      * ''object->nrof'':  This contains the number of an object. Since changing this will change the weight of an object, direct access should also be avoided.  Use ''decrease_ob_nr'', ''split_ob'', ''and insert_ob_in_...'' - the later will merge the objects if applicable.
    - If using ''insert_ob_in_map'' and plan to do further actions with the object, check and make sure the object still exists after insertion - it is possible that the object gets destroyed while being inserted (eaten by an altar or such).
@@ -13,73 +13,103 @@
  
  
  ====== Section 2 - Style guide for new additions: ======
  
-   - Use descriptive variable names.  op and pl should only be used for temporary variables (cycling through the list or the like).  For variables well defined, use an accurate name (ie, hitter, sack, etc).
-   - Only add name options with #ifdef's to the config file if the behaviour seriously changes the game.  Adding a new spell does not warrant an #ifdef. There are already too many options in the config.h file.
+   - Use descriptive variable names.  ''op'' and ''pl'' should only be used for temporary variables (cycling through the list or the like).  For variables well defined, use an accurate name (ie, hitter, sack, etc).
+   - Only add name options with //#ifdef'//s to the ''config'' file if the behaviour seriously changes the game.  Adding a new spell does not warrant an //#ifdef//. There are already too many options in the ''config.h'' file.
    - Log errors/diagnostics with the LOG function.  When doing so, please include the function name - this is especially true for errors.
-   - If you want to add special debug code for certain compiles, generate a unique #define for it - don't use the global DEBUG.  For example, NEWCS_DEBUG.
+   - If you want to add special debug code for certain compiles, generate a unique //#define// for it - don't use the global DEBUG.  For example, NEWCS_DEBUG.
    - Try to use the [s/u]int[8/16/32] whenever possible.  Use the one of appropriate size/type.  If not sure, go for the next size up.  Do not ever write code assuming that any of those will have an exact number of bits - those types only mean that you will get at least that many bits - you may get more.
-   - The exception to #5 above is strings.  Continue to use 'char', since the signedness of functions that take string options can differ system to system, and generate excessive warnings if the wrong sign is used.
+   - The exception to #5 above is strings.  Continue to use //char//, since the signed-ness of functions that take string options can differ system to system, and generate excessive warnings if the wrong sign is used.
    - When adding new function, include a comment of what the function is supposed to do, what options it takes, and what if any value it returns. This makes debugging of such functions easier, and also makes it better known to other developers if that function might be useful to them.
-   - Try to keep lines to less than 80 columns when possible.  This is not a strict requirement - don't break up some complex comparison because the line would otherwise be 83 characters long.  Xterms can be resized to most any width.  However, use your judgement on whether breaking up a long line would make something more or less readable.
-   - Assume all names use one namespace.  For example, if there is a struct called ''spell'', don't make the name of an optional parameter spell. This will break on ANSI C compilers that follow the spec strictly (gcc does not, even with -strict -ansi)
-   - As a followup on 9 above, don't use nonstandard gcc extensions (// for comment lines, ability to nest functions, declare arrays with variable bounds, etc.)  Likewise, don't use special system functions - don't assume the target system will be bsd or svr4 - if using a potentially non standard function, add checks in the autoconf script and include a version of the function in case it is not on that system.  They key word here is portability - don't assume everyone else has the same system as you do.
-   - Write code that can easily be maintained in the future, not code that is easiest to write at that second.  This basically means don't do the quick and ugly hack, but instead fix it properly.
-   - Use 4 space indentation.  While a lot of old code may have 2 space, the move to 4 space will make future readability easier.
-   - <code>/*
-   * do block
-   * comment like
-   * this
+   - Try to keep lines to less than 80 columns when possible.  This is not a strict requirement - don't break up some complex comparison because the line would otherwise be 83 characters long.  Xterms can be resized to most any width.  However, use your judgment on whether breaking up a long line would make something more or less readable.
+   - Assume all names use one name space.  For example, if there is a //struct// called ''spell'', don't make the name of an optional parameter spell. This will break on ANSI C compilers that follow the spec strictly (gcc does not, even with -strict -ansi)
+   - As a followup on 9 above, do not use non-standard gcc extensions (%%//%% for comment lines, ability to nest functions, declare arrays with variable bounds, etc.)  Likewise, do not use special system functions, for example, do not assume the target is a BSD or SVR4 system.  If a potentially non-standard function must be used, add checks in the autoconf script and include a version of the function in case it is not on that system.  The keyword here is portability; do not assume everyone else has the same system you have.
+   - Write code that can easily be maintained in the future, not code that is easiest to write quickly.  In other words, do not do the quick and dirty hack, but instead always write code with maintainability and clarity in mind.
+   - Use 4 space indentation.  While a lot of old code may use 2 spaces, a move to 4 spaces makes readability easier.
+   - Files are created with standard content blocks.<code> char *rcsid_component_file_ext =
+      "$Id: file.ext$";
+  /*
+   * Project name, brief description
+   *
+   * Copyright information
+   *
+   * GPL blurb here
+   *
+   * Contact information
+   */
+ 
+  /**
+   * @file file.ext
+   * A brief description.  Detailed information may follow.
+   */</code>
+     * The //rcsid_// variable is useful for creating error and debug messages.  For //component//, look at other files nearby. 
+     * The @file comment block helps doxygen create meaningful output.
+     * The license block requirement is obvious.
+   - Functions are documented like this.<code> /**
+   * A brief descriptive sentence summarizes the function.  An overview ends
+   * at the first period and space, then the detailed information follows.
+   *
+   * @param bla
+   * This is a parameter
+   * @return
+   * returns NULL
+   */</code>
+     * This lets doxygen generate nice documentation.
+   - Use the following block commenting style.<code> /*
+   * Do block comments like this.
+   * Get in the habit of using a
+   * brief and detailed style.
    */
  
    /*
      and not
      like this
     */
  
-   /* if you are doing a single line comment, this method is fine */</code>Its much easier to spot the block comments if they all start with *, and these comments tend to be worth noticing.
-   - <code> /**
-   * Functions should be commented like this.
-   *
-   * @param bla
-   * this is a parameter
-   * @return
-   * returns NULL
-   */</code> This lets doxygen generate nice documentation.
+   /* but single line comment using this method is fine */</code>
+     * It is much easier to spot the block comments if they all start with *, and they tend to be worth noticing.
    - As discussed on irc, the preferred style for expressions is like this:<code>
  if (expression) {
    statement;
    statement;
  }
  </code>if <space> (expression), the space between the if and expression is required.\\ NOT like this:<code>
- if (expression)
+ if(expression)
  {
    statement;
    statement;
  }</code>
    - The preferred style of formal parameters:<code>
  void myFooFunction(param1, param2, param3) {
    statement;
    statement;
- }</code>No space after the left paren, no space before the right paren. Comma right after the formal param, space right after the comma.  
-   - Local variable names. Just a rules of thumb. This are ok:<code>
+ }</code>
+     * No space after the left parenthesis
+     * No space before the right parenthesis
+     * Comma right after the formal parameters
+     * Space after the commas.  
+   - Local variable names. Just a rules of thumb. These are ok:<code>
  int mylongvarname;
  int my_long_var_name;
- </code>Please do NOT use caps expect for typedefs, enums and defines.
+ </code>
+     * Do NOT use caps except for typedefs, enums and defines.
+   - To document variables in doxygen, format the comment as shown below:<code>
+ int my_var_name; /**< Raison d'etre.. */
+ </code>
  
  
- ====== Section 3 - sending in patches: ======
+ ====== Section 3 - Sending in patches: ======
  
-   - Please send patches on a bug fix or feature enhancement basis individually, and not make mega patches.  A diff that changes 10 things is first more difficult for developers to look over and understand as unrelated changes might be going on.  It is also harder to reject part of a patch (feature X is nice, but Y doesn't work).
-   - Please state in the message included with the patch what it fixes/changes. Too often, we get patches which is just a bunch of source code, and we have no idea if I want to incorporate it, or even if the bug is still there. Please also state what version of crossfire the diff is for.
-   - I will assume any patches mailed directly to me are to be included. If posting a patch on the mailing list (either source or ftp location), please explicity state whether or not you want that patch incorporated into the master source.  Many times, a patch may be made available on an expiremental basis which is not ready for widespread distribution.  
-   - When making patches, please make context diffs.  Please also include the directory that the file is in (run the diff in the top level directory).  Please make 5 line context diffs - large line context diffs are fine if you think that may make it easier.\\ Example:<code>
+   - Send patches on a bug fix or feature enhancement basis individually, and do not make mega-patches.  A diff that changes 10 things is more difficult for developers to review and understand as unrelated changes might be going on.  It is also harder to reject part of a patch (feature X is nice, but Y doesn't work).
+   - Please state in the message included with the patch what it fixes/changes. Too often, patches are just a bunch of source code, with no indication why it should be incorporated.  Without such commentary, it may be difficult to even determine if the bug it fixes is still there in the source it patches. Please also state what version of crossfire the diff is for.
+   - I will assume any patches mailed directly to me are to be included. If posting a patch on the mailing list (either source or ftp location), please explicitly state whether or not you want that patch incorporated into the master source.  Many times, a patch may be made available on an expirimental basis which is not ready for widespread distribution.  
+   - When making patches, please make context diffs.  Please also include the directory that the file is in (run the diff in the top level directory).  Please make 5 line context diffs - larger line context diffs are fine if you think that may make it easier.\\ Example:<code>
  diff -c5 (oldfile) (newfile)</code>You can also do diffs of entire directories.  Do do this, type:<code>
  diff -c5 -r (old_directory) (new_directory)</code>An example:<code>
  diff -c5 -r crossfire-0.90.1 crossfire-0.90.2</code>
    - Gnu diff will include files that did not exist before.  Other diff programs may not do this.
    - If your diff looks excessively long and you made a lot of formatting changes, you can add -w to the diff options to have it ignore whitespace. Note that this will then mean that those formatting changes will then be lost.
-   - There is no need to make a seperate diff file for each file different (ie, treasure.diff, player.diff, etc).  Assuming you follow steps 1-6, all the diffs can be contained in one file, and patch will deal with it just fine.
-   - If you need to send a map, new archetypes, or other new files where a diff doesn't make sense, a uuencoded tar file will work just fine.
+   - There is no need to make a separate diff file for each file that is different (ie, treasure.diff, player.diff, etc).  Assuming you follow steps 1-6, all the diffs can be contained in one file, and patch will deal with it just fine.
+   - If you need to send a map, new archetypes, or other new files where a diff doesn't make sense, a uuencoded tar file will suffice.
  
  Submit all patches to the Sourceforge patch tracker on http://sourceforge.net/projects/crossfire, and mail an announcement to [[crossfire-devel at lists.real-time.com]].


IP-Address  : 66.137.82.229
Old Revision: http://wiki.metalforge.net/doku.php/coding_style_guide?rev=1174564935
New Revision: http://wiki.metalforge.net/doku.php/coding_style_guide

-- 
This mail was generated by DokuWiki at
http://wiki.metalforge.net/




More information about the crossfire-wiki mailing list